About

Browser Compatibility

MetService endeavours to ensure the website runs smoothly on the following browsers:

BrowserWindowsMacLinux
Firefox 3.5, 4.0, 5.0 - 27.0 3.5, 4.0, 5.0 - 27.0 3.5, 4.0 - 27.0
Chrome 1.0, 3.0.1, 10.0, 12.0 - 32.0 4.0, 10.0, 12.0 - 32.0 up to 32.0
Internet Explorer 7.0, 8.0, 9.0, 10, 11 n/a n/a
Safari 5.0 6.0, 7.0 n/a