Our Company

MetService Apps Security Update

 

TLS Security updates

In early 2020 all major internet browsers will no longer support Transport Layer Security (TLS) 1.0 and 1.1 due to security concerns. To ensure the privacy, integrity and protection of the data provided through our apps the MetService Marine, Snow and Rural apps will soon stop supporting devices relying on these outdated technologies.

TLS 1.0 and TLS 1.1 are considered unsafe because they are now outdated and vulnerable to malicious attacks. Most mobile devices already use newer, more secure versions of TLS.

We expect this change to only effect devices using iOS 8.1 or older, or, Android 4.4 (KitKat) or older, but other devices which use alternative versions of Android may also be affected – If your device is using one of these affected operating systems, you will need to update or upgrade to continue using these apps.

 

For information on updating your Android operating system click here

For information on updating your Apple iOS operating system click here